Reply – Can't get canplayer to work
Your Name
or Cancel
In Reply To
Can't get canplayer to work
— by arthurnunesq arthurnunesq

I'm trying to use canplayer to replay some candump files, with no success. When I try to run the canplayer it just executes and returns, giving me no clue of what is happening.

What I've tried up to now:

Setup 1
- Set up a vcan interface
- Sent data to the vcan interface using cansend and cangen, with success (verified with candump).
- Recorded a candump file from vcan0 when running cangen. Recorded files with absolute timestamps (-t a) and without.
- Tried using canplayer to reproduce the file. Tried using several arguments, no avail. canplayer just returns immediately without any complaint. If I mess up the the file or arguments it complains.

Setup 2
- Connected 2 PEAK CAN USB adapter devices to the PC.
- Connected the adapters to each other using a 120ohm terminated cable
- Started cangen pointing to can0 and verified that the messages got to can1 using candump
- Recorded candump files from can0 interface.
- Tried using canplayer to reproduce the file., with no success.

I've tried these tests on two different machines, both running Ubuntu 12.04, with the same results.

Do you know what might be the cause of it?
Is here the right place get some advice, or is there an official forum only for canutils?

Any help would be appreciated.

Thank you,